
oit
UMass Offi ce of Information Technologies

OIT Academic Computing
Lederle Graduate Research Center

University of Massachusetts Amherst 

Phone: (413) 577-0072

Email: instruct@oit.umass.edu

http://www.oit.umass.edu/academic

Working with Images in Dreamweaver
Steps for using images in Dreamweaver:

 Step 1: Resize an image in Photoshop 2

 Step 2: Save the image for the Web 2

 Step 3: Insert an Image in Dreamweaver 3

 Step 4: Examine and edit image attributes 3

About using images in Dreamweaver 4

What if I want to edit an image that is already in Dreamweaver? 5

Appendix A:  Troubleshooting   6

Appendix B:  Image Optimizing -- GIF or JPEG? 8

Appendix C:  Web fi le naming conventions 9

Appendix D:  Banners and Buttons  10

Dreamweaver MX 2004 & Dreamweaver 8

October 2007



Working with images in Dreamweaver Page 2

OIT Academic Computing, University of Massachusetts http://www.oit.umass.edu/academic                                                      071019

Steps for adding images to a Web Page 
in Dreamweaver
Step 1: Resize an image in Photoshop
Before an image can be inserted into a Web page, it must be fi rst resized 
to the dimensions (in pixels) it will appear on the page.

Open Photoshop and go to File > Open, then select the image 
that you want to edit and click Open.

Go to Image > Image Size.
The current dimensions of your image will be displayed.  

At the bottom of the Image Size window:
Check Constrain Proportions to maintain the proportions of 
the image when it is resized.  (You will only need to enter a new 
value for one dimension, the software will compute the other.)

Also check Resample Image.
Resampling means that the dimensions (in pixels) of the image 
will be changed.  Photoshop calculates values for new pixels or 
removes pixels from the picture.

In the top area, under Pixel Dimensions, Units should be 
set at Pixels.  

Enter the new, smaller, dimension for width or height.  (See size 
guidelines.)

Click OK.

Step 2: Save the image for the Web
In order to show in a browser, images must be saved in a Web friendly 
format.  The two most comon fi le types used for Web pages are GIF and 
JPEG.  (See Appendix 2 if you need help determining the best fi le type 
and compression for your image.)

Choose File > Save for Web.

A dialog box will open up, showing the  image on the left, with 
settings option on the right.

  If you do not see 4 versions of your image on the screen, click the 
4-UP tab at the top of the dialog box.

1.

2.

3.

4.

5.

6.

7.

1.

2.

Keeping track of “source” documents
We recommend storing your “raw” content 
along with your Web site fi les, but in a different 
folder than your local root folder.  Along with 
your orignal image fi les, this might include 
Word documents, scans, or ditial camera 
images.

We typically use a fi le hierarchy similar to the 
one shown below.

Click the 4 UP tab to see comparisons.

File Size Guidlines
Your goal is to keep fi le size as small as 
possible, but still mantain adequate image 
quality.  Aim for sizes in these ranges...

Use            Pixel DImensions File Size

Buttons:    15 x 60 < 10 K

Thumbnails:    75 x 75 < 20 K

Banners/Logos:   50 x 20 < 30 K

Illustrations:     200 x 300 < 50 K
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       3. Start by selecting the image compression format you think is  
             appropriate in the settings box: GIF or JPG.  (See Appendix B                        
             if you’re not sure.)
       4.  Choose other settings such as number of colors  or degree of 
 compression, then check the results in the preview boxes.  
 Information for each variation is shown at the bottom left of 
 each preview: compare quality versus fi le size.
       5.  Continue to reduce colors (GIF) or quality (JPEG) until both the 
 fi le size and the quality are acceptable.
      6.  Click “OK”.  
      7.  Give the fi le a new name.  Use Web fi le naming conventions 
 (See Appendix C).
 Make sure the fi le is saved in the images folder of your website 
 fi les.  Click “Save”.

Step 3: Insert the Image in Dreamweaver
In Dreamweaver, open the fi le in which you wish to insert an 
image.

Place the cursor in the place where you want your image to be 
inserted.

Choose Insert > Image.
The Select Image Source window will open.  Choose the image 
that you want to insert. Click Choose.

Your should now see your image on the  page.

Step 4: Examine and edit image attributes
Click an image in your Dreamweaver page.
The Properties Inspector will change to show attributes for that 
image.

Provide Alternate Text
1.  On Dreamweaver, select the image.

2.  In the Properties Inspector, give the image an ALT tag.
If the image is a button showing text, make the ALT tag say exactly 
what the text says.  If the image is a photo or illustration, describe the 
contents of the image.

1.

2.

3.

1.

•  Click on the Image 
    icon in the Object
    Panel

•  Press CONTROL + 
    ALT + I

•  Drag and drop the 
   image icon out of the
   Site Files window,
   onto the page

Alternate methods for 
inserting an image

width & height attributes ALT attribute

Reset size button (only shows if size is set to other than true pixel 
dimensions of image)

File path to image source

If the image is a link, fi le path to target page will show here

If you Don’t have Photoshop
Any Basic image editing software should be 
able to accomplish the tasks described on this 
page.  Some common, less expensive options 
are PaintShop Pro, Macromedia Fireworks, or 
Adobe’s scaled down version of Photoshop: 
Photoshop Elements.

If you are only trying to shrink an image 
slightly, this can be done in Dramweaver.  
For instructions on how to do this, see the 
setion “If you decide to edit an image in 
Dreamweaver.”

Why give images ALT attributes?
•  ALT tags make pages accessible to non-
graphical browsers and to disabled users who 
rely on assistive technologies to access the 
Web.

• Some people browse with images turned off.  If 
your image contains important content, such as 
a navigation button made in Photoshop,  users 
won't see what the button "says."
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Image Alignment
Image Align attributes affect not only where the image appears, but how 
text aligns to the image.

1. Click after the image and insert several lines of text. 

2. Reselect the image, then go to the Properties Inspector and change the 
Align attribute.  Watch what happens as you use each option.

Create a margin around an image
With the image selected, go to the Properties Inspector and add 
V and H space values (vertical and horizontal padding).  

 Make an image into a link
Click the image to select it, then go to the Property Inspector.  
The link interface for images is exactly the same as it was for 
text.  Link the image to one of your other pages.

Save the page.

To preview your page in a browser, press F12 and test the link.

About using images in Dreamweaver

You need a separate image fi le
Images are separate fi les that are displayed within a Web page.  Image fi les 
must be saved within the Local Root folder. You can use the same image 
on different pages and include only one copy of the image fi le in your site 
fi les. 

Keep images in their own folder
If you built a “fl at” site without sub-folders, all the fi les would show in one 
long list, sorted alphabetically, not logically. 
It is much easier to maintain a site where fi les are organized into folders.  
Using an images folder is a great start to reducing clutter.  If you build a 
large site with a lot of images put an image folder inside the sub-folder for 
each topic. 

Always give Height & Width
Height and Width attributes make pages appear faster  in a browser.  
Dreamweaver automatically fi lls in H & W attributes every time you insert 
an image. 

Use images with their actual pixel dimensions
It is not a good idea to change the dimensions of an image in the 
Properties Inspector or by dragging on the “handles” a selected image!  

1.

1.

2.

3.

Default inline image            Image align = “left”                     Image align = “right”

Why you don’t want to “force” an 
image to appear smaller or larger...
A large image forced to look smaller will take a 
long time to download, and in some browsers 
it will print at actual size (covering other parts 
of the page!). 

A small image forced to appear larger will look 
mushy and pixellated. 
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What if I want to edit an image that is already 
in Dreamweaver?
In this case, you have two options:

Option 1:
Open the image fi le in Photoshop or another image editing 
software.

Edit and save based on steps 1 and 2 described at the begining 
of this handout.

 In Dreamweaver, remove the old version of the image fi le, and 
replace by inserting the new version of the image (steps 3 and 4 
above).

This option will avoid possibilities of distorting the image that are more 
likely when editing an image in Dreamweaver.

Option 2:
Dreamweaver provides very basic tools for editing images: you can 
shrink the pixel dimensions, crop, or make rough adjustments.
In this case, it is important to note:

WARNING:  Editing an image in Dreamweaver in any way will 
PERMANENTLY ALTER the fi le -- make sure you have a backup 
copy!

To shrink an image already on a page in Dreamweaver: 
Click on the image, then hold down the SHIFT key (keeps proportions) 
and drag the CORNER handle in until the image is the correct size. 
Now, (IMPORTANT!) click the Resample button: 

Dreamweaver will shrink the actual pixel dimensions.  

1.

2.

3.

TIP: Only shrink, don’t enlarge images. If 
you want to enlarge, you’ll have more control 
working with image editing software (e.g., 
Photoshop).
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Appendix A:  Troubleshooting  

Why is the image on my page stretched out?

Problem: The image has been given width and height 
attributes that do not match its actual pixel dimensions.

If you shrink an image using the image width and height attributes on the 
Properties Inspector, or using the “handles” you get when you click on an 
image in Dreamweaver,  the image may become distorted. 

Solution: Reset the image width and height to its actual pixel 
dimensions.

Dreamweaver MX 2004:  If the image dimensions have been 
forced in HTML, you will see a refresh icon on the Properties
Inspector next to the width and height attributes. 

If you do not see the refresh icon, the pixel dimensions are accurate.

Note: For previous versions of Dreamweaver, click the image, then click 
Reset Size on the Properties Inspector. If the image changes size, the 
dimensions had been forced.

2. Click the Reset button. If needed, crop or resize the image in an 
image editing application such as Photoshop, Photoshop Elements, 
Fireworks, PaintShop Pro, Microsoft Photo Editor, or Microsoft Image 
Manager.

1.

refresh icon = image H or W attributes do 
not match actual pixel dimensions

No refresh icon = image H and W attributes 
are true pixel dimensions
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Appendix A:  Troubleshooting Continued 

My page looks fi ne in a browser, but when I 
print the page, images print too large or   
 cover the text.

Problem: The pixel dimensions of the image fi le do not match 
the Width & Height attributes for the image.  

If you shrink an image using the “handles” you get when you click an 
image in Dreamweaver, Dreamweaver simply assigns new Width and 
Height attributes, which forces it to display larger or smaller in the 
browser. If you “shrink” the image in Dreamweaver, visitors to your site 
will experience unnecessarily slow download times.  Also, the page may 
print with the image printing at its true size in pixels, so that an image 
covers other parts of a page.

Solution: Resize the image.
Click the image. Make a note of the W (width) and H (height) 
dimensions for the image shown in the Properties 
Inspector.

Dreamweaver MX 2004:  If the image dimensions have been forced in 
HTML, you will see a “refresh” icon on the
Properties Inspector next to the width and height attributes. The 
refresh icon will disappear after you click it and the 
 image displays its true size. 

If you do not see the refresh icon, the pixel dimensions are accurate.

Note: For previous versions of Dreamweaver, click the image, then click 
Reset Size on the Properties Inspector.
If the image changes size, the dimensions had been forced.

2. Click Reset. If needed, crop or resize the image in an image editing 
application such as Photoshop, Photoshop Elements, Fireworks, PaintShop 
Pro, Microsoft Photo Editor, or Microsoft Image Manager.

1.

2.

refresh icon = image H or W attributes do 
not match actual pixel dimensions

No refresh icon = image H and W attributes 
are true pixel dimensions
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Appendix B:  Image Optimizing -- GIF or JPEG?

Saving a fi le for the Web in Photoshop
GIF or JPEG?

Use the GIF format for images with fl at areas of color
GIF compression works best when there are a lot of pixels with the same 
color next to each other in an image. 

Examples of images best saved as a GIF
Charts, buttons and banners, diagrams, line art, fl at illustrations, text...

Use the JPEG format for photographic images
JPEG compression works best when there are many pixels with many 
different colors and shades of colors in an image. JPEG images always 
contain millions of colors. On monitors with fewer colors, JPEG images are 
automatically dithered.

Examples of images best saved as  JPEGs 
Photographs and continuous tone illustrations          

In Photoshop, use ‘Save for Web’ command to pick the best fi le 
format

Some images fall in the borderline between “continuous tone” and “fl at” 
color.  Use the previews in Photoshop’s Save for Web dialog box to compare 
the image quality and fi le size outcomes of different format options before 
you decide which format is best.

Good Practice:  Save a copy of the original fi le in 
Photoshop format
GIF and JPEG formats compress image information.  Compressed pictures 
transmit more quickly over the Internet, but compression also degrades 
image quality. Compressing fi les also loses Photoshop-specifi c information 
such as layers and editable effects.  

Before you fl atten and compress an image as a GIF or JPEG, save the 
Photoshop fi le in a “Sources” folder in order to keep it safe for later 
alterations. 

What happens if you save a 
photo as a GIF?
• The fi le size of a photo 
   saved as a GIF is often 
   larger  than if the same 
   image is saved as a JPEG.
   Plus, it looks better as a 
   JPEG. 

• The image will often look dithered.

What happens if you save 
fl at color as a JPEG?
• The fi le size will  be no  
   smaller than  a GIF.

• Distortions (called artifacts) 
   will appear in the fl at areas 
   of the image.

JPEG at 60 quality
4 K
2 sec @ 28.8Kbps

GIF  128 color
6 K
3 sec @ 28.8Kbps

JPEG at 30 quality
1 K
1 sec @ 28.8Kbps

GIF    32 color
1 K
1 sec @ 28.8Kbps
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Appendix C:  Web fi le naming conventions

Naming Conventions for Web Files and Folders

Recommendations for trouble-free fi le and folder names

•  Do not use spaces in fi le or folder names.

•  Use only alphanumeric characters, dashes, and underscores.

 Characters you must avoid include:

   / ! @ # $ } { % ^ & * ( ) + | . , : “

•  Use all lowercase characters to prevent naming errors.

 Unix is case sensitive. If you mis-type the case in an HTML reference, 
the Web server will not fi nd the fi le.

•  Use the proper fi le type extension (the three characters that come after 
the document name) for the fi le type.
(If you save an image in the JPG fi le format, but the fi le name is 
image.gif, visitors will see a broken image icon)

• Keep fi le names as short as possible, but they should make sense.  
Files names that are excessively long (more than 27 characters) will 
cause problems, 8 characters (plus three for the extension) is ideal but 
not required. 

• Sensible fi le names make URL's easy to communicate.

 Avoid arcane acronyms or abbreviations. Sensible is more important 
than short!  Can you read the URL over the phone?

Why do my pages look fi ne from my own computer, but not 
from the Web server?

If you put spaces or other “illegal” characters in fi le or folder names, your 
pages may seem fi ne if  you preview the pages in a browser from fi les 
stored on your local computer, but then, when you upload them to the 
server and look at them over the internet things go wrong! 

Recommended

page_one.html

page-one.html

pageone.html

page_1.html 

Not recommended
(may cause errors)

page_one   (no fi le extension)

this_is_page-one.html   (too complex)

PAGE_ONE.HTML  (all caps*)

PageOne.html   (mixed case*)

Invalid
(will cause errors)

page one.html   (includes space)

page”1".html   (quotes)

page(1).html   (parenthesis )

page/one.html   (slash) 
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Appendix D:  Banners and  Buttons

Creating Banners & Buttons Using the Text tool in 
Photoshop

Graphical banners (mastheads) and buttons create interest and allow for more 
typographic style than HTML text. 

1. Choose File > New to create a new fi le. Make the page 50 pixels high, and 300 
pixels wide (you can crop it later if need be).  Set the Resolution to 72 ppi and 
the color Mode to RGB. (RGB is necessary to use all the features and tools  of 
Photoshop.)  
Click OK.

2.  If you want a colored background...
At the top of the screen choose Layer > New Fill Layer > Solid Color.

From the color dropdown  menu, choose the general shade of the color you 
want for the background (you can be more specifi c on the next screen). 
Click OK.
This will open the Color Picker Screen.  Make sure Only Web Colors is 
selected.  Choose the color you want for the background.  Click OK.

 (Warning: Saturated colors make text hard to read, avoid overly intense colors.)

3.   Get the Text tool from the Toolbox and click in the document window where 
you want the text to start.  Make changes to the text style  (font, size, color, 
etc.) in the options bar.  
Choose colors carefully, this color should contrast with your background color 
in a way that keeps the text readable: the text color should be signifi cantly 
darker or lighter than the background.

 
Additional options can be found by clicking on  the “Text Palette” 
icon in the option bar.

4. Click on the check button in the options bar when you are done typing.

 Note:  new layer is created for every text entry.   

 To edit a text layer, fi rst click on the layer name in the Layers palette, then click 
in the line of text in the document window.

Special Effects on Text:

 Layer Styles can be applied to text layers
1. From the Layer > Styles menu you can apply a variety of simple effects, 

including drop shadows and embossing. The text can still be edited. The effects 
show as a sub-layer which can be hidden or discarded as needed.

 Filters can only be applied to “rendered” text
 NOTE: Rendered text becomes an image and can no longer be edited with the text 

tool. We suggest you work on a duplicate layer to test fi lter effects.

1.   In the Layers palette, click on the text layer name, then go to Duplicate Layer 
from the palette menu. Hide the original text layer (click the ”eye” in from of 
the layer).

2.   In the Layers palette, click on the name of the duplicate layer, then from the 
Layer menu select Type > Render Layer. You can now apply fi lters.

Text tool options


